Fehler 500 wenn ich versuche allow_url_fopen off zu stellen

Wie wir alle wissen (sollten) ändert mod_rewrite keine Links im Script. Damit auch die Links auf Deiner Page auf die neuen "Rewrited URLs" zeigen bedarf es der Anpassung im Code. Fragen und Probleme rund um's Coding werden hier diskutiert.

Moderator: Super-Mod

Fehler 500 wenn ich versuche allow_url_fopen off zu stellen

Beitragvon toasti » 19.07.2009 16:54

Hallo,
ich bin grad dabei mich durch einen haufen .htaccess meines Forum Vorgängers durchzuwühlen.
Gleich auf oberster Ebene hab ich einen Aufruf den ich auskommentieren muß, weil er sonst einen 500 Fehler bringt. Zumndest seit einem Serverumzug.
Da allow_url_fopen auf meinem Server auf ON steht, würde ich per htaccess das ganze auch gerne weiterhin wieder einschränken.

Dort steht:
Code: Alles auswählen
php_flag allow_url_fopen off

Ist dieser Aufruf Falsch? Mit php_value würde es ja auch nicht gehen.

Der jetzige Abschnitt dazu sieht so aus:
Code: Alles auswählen
RewriteEngine On
# php_flag register_globals off
# php_flag allow_url_fopen off
# php_flag magic_quotes_gpc on
AcceptPathInfo on

# RewriteCond %{HTTP_HOST} ^www\.wiki\.deskmodder\.de$ [NC]
# RewriteRule ^(.*)$ http://www.deskmodder.de/wiki/$1 [L]
# Redirect permanent /phpBB2 http://www.deskmodder.de/phpBB3

Alles was ich da schon per # auskommentiert habe, würde mir einen 500er bringen.

Kann mir da mal jemand sagen wo mein Denkproblem liegt?
Vielen Dank und digitale Grüße
Toasti
toasti
.
.
 
Beiträge: 3
Registriert: 16.07.2009 10:35

Beitragvon Gumbo » 19.07.2009 17:22

„php_flag“ und die anderen „php_“-Direktiven sind nur dann möglich, wenn PHP also Modul läuft und für das Verzeichnis „Options“ und „FileInfo“ erlaubt ist.
Markus Wulftange
Gumbo
Moderator
Moderator
 
Beiträge: 5019
Registriert: 07.01.2005 01:18
Wohnort: Trier

Beitragvon toasti » 19.07.2009 17:45

Au fein, da kommt Leben in meine Hirnwindungen, ich verstehe nämlich grad nur Bahnhof.

Die Einstellung AllowOverride All suche, bzw. finde ich wo? httpd.conf vom Apache?
Und sie müsste auf All stehen damit meine Angaben in der htaccess genommen werden würden?

Ganz ignorieren scheint er meine .htaccess Dateien ja nicht, sonst würde zwischen An und Aus ja auch kein Unterschied bemerkbar machen.
Aber in der Php.ini habe ich zu AllowOverride nichts gefunden. oder stehe ich jetzt völlig auf dem Schlauch und denke in die falsche Richtung?
Digitale Grüße und Danke
Toasti
toasti
.
.
 
Beiträge: 3
Registriert: 16.07.2009 10:35

Beitragvon Gumbo » 19.07.2009 18:16

„All“ enthält neben anderen Einstellungen auch „Options“ und „FileInfo“. Und die Einstellung müsste in einem „<Directory>“-Block in der Server- oder Virtueller-Host-Konfiguration vorgenommen werden.
Markus Wulftange
Gumbo
Moderator
Moderator
 
Beiträge: 5019
Registriert: 07.01.2005 01:18
Wohnort: Trier

Beitragvon toasti » 20.07.2009 00:37

Okay, vielen Dank, habs hinbekommen und nun laufen sie
Digitale Grüße und Danke
Toasti
toasti
.
.
 
Beiträge: 3
Registriert: 16.07.2009 10:35


Zurück zu Programmierung & Scriptanpassung für mod_rewrite

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 0 Gäste