mod_rewrite funktioniert, adresszeile bleibt

Wie wir alle wissen (sollten) ändert mod_rewrite keine Links im Script. Damit auch die Links auf Deiner Page auf die neuen "Rewrited URLs" zeigen bedarf es der Anpassung im Code. Fragen und Probleme rund um's Coding werden hier diskutiert.

Moderator: Super-Mod

mod_rewrite funktioniert, adresszeile bleibt

Beitragvon Nico2M » 20.01.2009 05:29

Hallo liebe Leute,
ich sitze nun schon die ganze Nacht an diesem Problem und finde einfach keine Lösung.

Ich hab bei meiner Page die Links folgendermaßen umgewandelt:
Eingabe: http://www.domain.tld/de/main/news
Führt zu: http://www.domain.tld/index.php5?module ... ws&lang=de

Das funktioniert auch wunderbar, nur dass statt der "Eingabe-URL" die "Führt zu-URL" in der Adressezeile nach dem Laden der Seite sichtbar ist.
Ich habe das ganze via Localhost gemacht, wo es auch tadellos funktioniert - dort sehe ich auch "http://localhost/www.domain.tld/de/main/news" statt der anderen URL,
sobald ich die Seite dann aber auf den Server lade, zeigt er mir wieder die URL mit den Parametern an.

Die .htaccess sieht wie folgt aus:
Code: Alles auswählen
Options +FollowSymLinks
RewriteEngine On
RewriteBase /

RewriteRule ^([a-z]*)/main/news$ index.php?module=main&content=news&lang=$1

RewriteRule ^([a-z]*)/clan/member$ index.php?module=clan&content=member&lang=$1
RewriteRule ^([a-z]*)/clan/awards$ index.php?module=clan&content=awards&lang=$1
RewriteRule ^([a-z]*)/clan/wars$ index.php?module=clan&content=wars&lang=$1

RewriteRule ^([a-z]*)/community/replays/download/([0-9]*)$ index.php?module=community&content=replaydownload&lang=$1&replayid=$2
RewriteRule ^([a-z]*)/community/replays/upload$ index.php?module=community&content=replayupload&lang=$1
RewriteRule ^([a-z]*)/community/replays$ index.php?module=community&content=replays&lang=$1


Hat irgendjemand eine Idee? Ich wäre für jede Hilfe dankbar!
Nico2M
.
.
 
Beiträge: 2
Registriert: 20.01.2009 05:25

Beitragvon Nico2M » 20.01.2009 05:36

Oh mein Gott, entschuldigt bitte. Ich glaube ich sollte schlafen gehen und morgen mit klarem Verstand arbeiten *lach*
Habe das Problem gefunden, ich verweise die ganze Zeit auf index.php und nicht index.php5 in den RewriteRules :/

Ich Dummerchen.
Nico2M
.
.
 
Beiträge: 2
Registriert: 20.01.2009 05:25


Zurück zu Programmierung & Scriptanpassung für mod_rewrite

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast

cron