Es werden keine Bilder angezeigt

Wie wir alle wissen (sollten) ändert mod_rewrite keine Links im Script. Damit auch die Links auf Deiner Page auf die neuen "Rewrited URLs" zeigen bedarf es der Anpassung im Code. Fragen und Probleme rund um's Coding werden hier diskutiert.

Moderator: Super-Mod

Es werden keine Bilder angezeigt

Beitragvon traffic » 21.11.2008 16:38

Hallo,

ich wende folgende Regeln:
Code: Alles auswählen
RewriteEngine on

RewriteRule ^(.*).html$ index.php?main=$1 [QSA]
RewriteRule ^artikel/([0-9]+)/(.*)/$ /index.php?main=artikel&id=$1


Wenn Regel zwei eintritt werden jedoch keine Bilder angezeigt.
Hat jemand eine Idee warum?

MfG
Traffic
traffic
.
.
 
Beiträge: 6
Registriert: 06.04.2008 12:25

Beitragvon traffic » 21.11.2008 17:22

wenn ich es so mache, dann wird man nur weitergeleitet


Code: Alles auswählen
RewriteEngine on

RewriteRule ^(.*).html$ index.php?main=$1 [QSA]
RewriteRule ^artikel/([0-9]+)/(.*)/$ http://www.domain.de/index.php?main=artikel&id=$1
traffic
.
.
 
Beiträge: 6
Registriert: 06.04.2008 12:25

Beitragvon csskoeln » 21.11.2008 19:40

Moin,

Siehe hier:
http://www.modrewrite.de/foren/ftopic82.html

5. Einzelne Regeln laufen nicht oder nicht richtig


Edit:
Deine Regel 2 bezieht sich auf einen Unterordner, daher der Verweiß von mir auf den Artikel...
csskoeln
.
.
 
Beiträge: 35
Registriert: 08.08.2006 16:24
Wohnort: Köln

Beitragvon traffic » 23.11.2008 20:45

wenn ich diesen code verwende
Code: Alles auswählen
<base href="http://example.com">


funktioniert es nur bei firefox, nicht im IE.

Hat jemand eine Idee warum?
traffic
.
.
 
Beiträge: 6
Registriert: 06.04.2008 12:25


Zurück zu Programmierung & Scriptanpassung für mod_rewrite

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 0 Gäste