Nach Umbenennung in .htaccess: /shop/de/shop.html was not fo

Wie wir alle wissen (sollten) ändert mod_rewrite keine Links im Script. Damit auch die Links auf Deiner Page auf die neuen "Rewrited URLs" zeigen bedarf es der Anpassung im Code. Fragen und Probleme rund um's Coding werden hier diskutiert.

Moderator: Super-Mod

Nach Umbenennung in .htaccess: /shop/de/shop.html was not fo

Beitragvon modza » 05.05.2010 23:05

Hallo,

ja wie schon im Titel beschrieben habe ich ein Problem welches nach der Umbenennung der htaccess.txt nach .htaccess erscheint.
Ich nutze Joomla mit VirtueMart und versuche jetzt Suchmaschinenfreundliche URL's zu produzieren.
Dazu habe ich mir eine entsprechende Software geleistet. Vor der Installation der SEO Software war in der Anleitung die Umbenennung der htaccess verlangt worden.
Gesagt getan, aber speziell die Links für VirtueMart werden mit einem Fehler ausgegeben.

Fehler: Code 404 The requested URL /shop/de/shop.html was not found on this server.

Code von der .htaccess

Code: Alles auswählen
##
# @version $Id: htaccess.txt 14401 2010-01-26 14:10:00Z louis $
# @package Joomla
# @copyright Copyright (C) 2005 - 2010 Open Source Matters. All rights reserved.
# @license http://www.gnu.org/copyleft/gpl.html GNU/GPL
# Joomla! is Free Software
##


#####################################################
#  READ THIS COMPLETELY IF YOU CHOOSE TO USE THIS FILE
#
# The line just below this section: 'Options +FollowSymLinks' may cause problems
# with some server configurations.  It is required for use of mod_rewrite, but may already
# be set by your server administrator in a way that dissallows changing it in
# your .htaccess file.  If using it causes your server to error out, comment it out (add # to
# beginning of line), reload your site in your browser and test your sef url's.  If they work,
# it has been set by your server administrator and you do not need it set here.
#
#####################################################

##  Can be commented out if causes errors, see notes above.
Options +FollowSymLinks

#
#  mod_rewrite in use

RewriteEngine On

########## Begin - Rewrite rules to block out some common exploits
## If you experience problems on your site block out the operations listed below
## This attempts to block the most common type of exploit `attempts` to Joomla!
#
## Deny access to extension xml files (uncomment out to activate)
#<Files ~ "\.xml$">
#Order allow,deny
#Deny from all
#Satisfy all
#</Files>
## End of deny access to extension xml files
RewriteCond %{QUERY_STRING} mosConfig_[a-zA-Z_]{1,21}(=|\%3D) [OR]
# Block out any script trying to base64_encode crap to send via URL
RewriteCond %{QUERY_STRING} base64_encode.*\(.*\) [OR]
# Block out any script that includes a <script> tag in URL
RewriteCond %{QUERY_STRING} (\<|%3C).*script.*(\>|%3E) [NC,OR]
# Block out any script trying to set a PHP GLOBALS variable via URL
RewriteCond %{QUERY_STRING} GLOBALS(=|\[|\%[0-9A-Z]{0,2}) [OR]
# Block out any script trying to modify a _REQUEST variable via URL
RewriteCond %{QUERY_STRING} _REQUEST(=|\[|\%[0-9A-Z]{0,2})
# Send all blocked request to homepage with 403 Forbidden error!
RewriteRule ^(.*)$ index.php [F,L]
#
########## End - Rewrite rules to block out some common exploits

#  Uncomment following line if your webserver's URL
#  is not directly related to physical file paths.
#  Update Your Joomla! Directory (just / for root)

RewriteBase /shop/


########## Begin - Joomla! core SEF Section
#
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_URI} !^ /index.php
RewriteCond %{REQUEST_URI} (/|\.php|\.html|\.htm|\.feed|\.pdf|\.raw|/[^.]*)$  [NC]
RewriteRule (.*) index.php
RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization},L]
#
########## End - Joomla! core SEF Section


Da der Shop in dem Unterverzeichnis /shop/ liegt habe ich aus #RewriteBase, RewriteBas /shop/ gemacht.
Löst aber leider nicht mein Problem.
Jemand eine Idee woran das liegen könnte?

P.S.: mod_rewrite läuft auf dem apache Server


MfG

modza
modza
.
.
 
Beiträge: 4
Registriert: 05.05.2010 22:26

Beitragvon modza » 07.05.2010 15:33

Ok, das Problem hat sich erledigt.
mod_rewrite war zwar installiert und aktiv, aber in der apache.conf musste vom Hoster noch eine Änderung vorgenommen werden.

Beste Grüße,

modza
modza
.
.
 
Beiträge: 4
Registriert: 05.05.2010 22:26


Zurück zu Programmierung & Scriptanpassung für mod_rewrite

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 0 Gäste

cron