domain.de/bla nach index.php?123

Wie wir alle wissen (sollten) ändert mod_rewrite keine Links im Script. Damit auch die Links auf Deiner Page auf die neuen "Rewrited URLs" zeigen bedarf es der Anpassung im Code. Fragen und Probleme rund um's Coding werden hier diskutiert.

Moderator: Super-Mod

domain.de/bla nach index.php?123

Beitragvon globestern » 09.10.2009 10:48

Code: Alles auswählen
RewriteCond %{HTTP_HOST} !^www\.domain\.tld$ [NC]
RewriteRule ^/bla http://www.domain.tld/index.php?123[R=301,L]


zur erklärung:

ich möchte domain.de/bla nach domain.de/index.php?123 weiterleiten
wichtig: es soll nur /bla weitergeleitet werden andere unterseiten sind nicht betroffen und sollten normal weiterlaufen!

zusätzlich soll ich noch:

domain.nl/bla nach domain.nl/index.php?321 weiterleiten

sprich:
der HTTP_HOST müsste erkannt werden und geprüft ob .nl / .de
das passiert ja mit:

Code: Alles auswählen
RewriteCond %{HTTP_HOST} !^www\.domain\.tld$ [NC]


dann wir der rewrite für /bla durchgeführt:

Code: Alles auswählen
RewriteRule ^/bla http://www.domain.tld/index.php?123[R=301,L]


klappt aber leider nicht, wo liegt der fehler?
andere rewrite rules funktionieren einwandfrei

mfg
globestern
.
.
 
Beiträge: 3
Registriert: 06.12.2007 21:59

Beitragvon Gumbo » 09.10.2009 17:01

Es kann mehrere Ursachen dafür geben. Aber die wahrscheinlichste ist, dass du die Regel in einer .htaccess-Datei verwenden möchtest, für die du jedoch den Pfadpräfix aus dem Suchmuster entfernen musst:
Code: Alles auswählen
RewriteCond %{HTTP_HOST} !^www\.domain\.tld$ [NC]
RewriteRule ^bla$ http://www.domain.tld/index.php?123 [R=301,L]
Markus Wulftange
Gumbo
Moderator
Moderator
 
Beiträge: 5019
Registriert: 07.01.2005 01:18
Wohnort: Trier


Zurück zu Programmierung & Scriptanpassung für mod_rewrite

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste

cron