Fehler 310 - Zu viele Umleitungen

URLs umschreiben, umleiten, blocken oder sperren - all das und noch viel mehr kann mit mod_rewrite erreicht werden. Mit regulären Ausdrücken, Conditions und Rules stehst Du auf Kriegsfuss? mod_rewrite macht nicht das was Du willst, oder funktioniert gar nicht? hier bist Du richtig!

Moderatoren: Bob, Super-Mod

Fehler 310 - Zu viele Umleitungen

Beitragvon Kighlander » 25.06.2012 18:37

Sooo....
Ersteinmal einen schönen guten Abend.
Da mich googlen nicht auf eine annähernd passende Lösung gebracht hat, bin ich über dieses Forum gestolpert und hab mich schnurstracks mal angemeldet.
Ich habe da (hoffentlich) ein sehr kleines Problem.

Erstmal einiges vorweg, da ich bereits zu einem ähnlichen Thema böse Kommentare bekommen habe.
Ich bin ein Autodidakt. Ich beschäftige mich mit Webdesign (Also auch das, was mit Photoshop & Co. zu tun hat) und auch mit Webentwicklung (Sprich PHP-Programmierung, einfache Lösungen selbst entwickeln). Und, was mich zu diesem Forum bringt, ich habe bisher mit .htaccess oder mod_rewrite nicht viel zu tun gehabt.

Ich habe mir schweißtreibend nen eigenen Webserver für daheim angeschafft und eingerichtet, der per DynDns auch von außen erreichbar ist.
So, nun zu folgendem Problem:
Meine Projekte liegen immer in einem Unterverzeichnis meines Servers, da ich das "root" Verzeichnis später für meine eigene Homepage nutzen möchte :)

Als Beispiel liegen meine Projekte also so:
Code: Alles auswählen
meinname.dyndns.org/
..projekt_1/
..projekt_2
..
..projekt_x


Nun möchte ich mit Zend etwas "rumspielen" (sprich mich schritt für schritt da einarbeiten)
Dafür brauche ich folgende Verzeichnisstruktur:
Code: Alles auswählen
..projekt_zend/
....application/
......controllers/
......models/
......views/
........scripts/
....library/
......Zend/
....public


So weit, so gut.
In dem projekt_zend Verzeichnis möchte ich eine Weiterleitung an das Unterverzeichnis public haben und im Verzeichnis public sollen alle Anfragen, die nicht auf js, ico,gif,jgp,png und css enden, auf eine dort enthaltende index.php umgeleitet werden.

Mein Problem besteht aber schon in der ersten Regel, die ich umgesetzt haben möchte.
Meine .htaccess sieht folgendermaßen aus:
Code: Alles auswählen
Options -Indexes +FollowSymLinks
RedirectMatch 301 http://meinname.dyndns.org/dummy(.*) http://meinname.dyndns.org.org/dummy/public/$1


Das Ergebnis: Ich bekomme im Browser (Google Chrome) folgende Fehlermeldung:
Die Webseite unter http://meinname.dyndns.org/dummy/public ... ic/public/ hat zu viele Umleitungen erzeugt. Das Löschen Ihrer Cookies für diese Website oder das Zulassen von Drittanbieter-Cookies könnte das Problem möglicherweise beheben. Sollte dies nicht der Fall sein, liegt eventuell ein Serverkonfigurationsfehler und kein Problem mit Ihrem Computer vor.
Vorschläge:
    Laden Sie diese Webseite später erneut.
    Weitere Informationen zu diesem Problem.

Fehler 310 (net::ERR_TOO_MANY_REDIRECTS): Zu viele Umleitungen.


Außerdem sieht meine Adressleiste folgendermaßen aus:
http://meinname.dyndns.org/projekt_zend/public/public/public/public/.../public/public/


Nun meine Frage: WAS könnte da schief laufen und wie kann ich das beheben ?

Falls es nötig wird, ich habe auch Zugriff auf die Konfigurationsdateien des Webservers (Apache2)

Ich freue mich über Lösungen, zumal ich bestimmt nicht der einzige bin, der dieses Problem hat ;)

Bis dahin,

Euer Kighlander
Dass die Vögel der Sorge und des Kummers über deinem Haupt fliegen, kannst du nicht hindern.
Doch kannst du verhindern, dass sie Nester in deinem Haar bauen.
(Chinesisches Sprichwort)
Kighlander
.
.
 
Beiträge: 1
Registriert: 25.06.2012 18:00
Wohnort: Hilter aTW

Zurück zu mod_rewrite

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 0 Gäste

cron