-f und -d scheinen nicht zu funktioneren

URLs umschreiben, umleiten, blocken oder sperren - all das und noch viel mehr kann mit mod_rewrite erreicht werden. Mit regulären Ausdrücken, Conditions und Rules stehst Du auf Kriegsfuss? mod_rewrite macht nicht das was Du willst, oder funktioniert gar nicht? hier bist Du richtig!

Moderatoren: Bob, Super-Mod

-f und -d scheinen nicht zu funktioneren

Beitragvon smantscheff » 16.08.2011 17:56

Ich möchte URLs umleiten, für die es keine Dateien oder Verzeichnisse gibt, um einen Cache zu implementieren. Die Konfiguration (in httpd.conf, nicht in .htaccess) sieht so aus:

Code: Alles auswählen
        <Directory /srv/xxx/htdocs>
                Options FollowSymLinks +Indexes

                RewriteEngine On
                RewriteCond %{REQUEST_FILENAME}     !-f
                RewriteCond %{REQUEST_FILENAME}     !-d
                RewriteRule ^text/([0-9]+)$             /page.php?id_text=$1  [QSA]
                RewriteRule ^([^/]+/)*([A-Za-z0-9_]+)$  /page.php?url=$2 [QSA]
        </Directory>

Aber *alle* Dateinamen, selbst die von vorhandenen Dateien, werden durch die RewriteEngine geschleust, wie das RewriteLog zeigt. Woran kann das liegen? Ich habe die RewriteCode auch testhalber in die umgebende VirtualHost-Konfiguration kopiert, aber das Ergebnis bleibt gleich.

Woran kann das liegen?
smantscheff
.
.
 
Beiträge: 1
Registriert: 16.08.2011 17:20

Zurück zu mod_rewrite

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast

cron